+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Some Preview interfaces in German, everything else English


(Guest) #1

Greetings all,

We’ve integrated Combit L&L version 18 with our product. I’m using the .NET component to produce reports.

When I create my list label object I am defining English as our language, IE:

ListLabel myListLabel = new ListLabel(LlLanguage.English);

Additionally, I explicitly define the language type (probably for no gain, but figured it wouldn’t hurt):

myListLabel.Language = LlLanguage.English;

We also ship the .lng files with our application.

Within our application we allow the user to select what they want to do with a report, preview, print or export it.

English appears on screen correctly when the user chooses their destination. The only case where we see German is if someone chooses to Preview, and then brings up a window from there (IE: tries to do a search from the preview window, or clicks the Export/Save As button in the preview window). So, for example, when someone clicks the Export button in the preview window, the interface is brought up in German.

I tried setting the HKCU\Software\combit\CMBTLL\LL18LangId to 1 (English) but that had no effect.

Recommendations?


(Guest) #2

Dear Matthew,
thank you for your post.

You also have a support case open on this, and we are working on the case.
You’d be welcome to post the results here in the forum. Thank you.

Kind regards

Erdal Alacali
Technical Support
combit GmbH


(Guest) #3

Just an update for everyone.

In my installation I was including the 64 bit English language file cxls1801.lng, but not the 32 bit language file cmls1801.lng. Our process is running as a 32 bit operation, so I included the 32 bit file and all was well.

Just FYI. Thanks to the Combit support team for their help!