+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Umstieg LL13 -> LL15: Felder und Variablen weg


(Guest) #1

Hallo!

ich bin gerade von LL13 auf LL15 umgestiegen, in Kombination mit Delphi 2010.

Leider habe ich das Problem, dass er beim Öffnen von bestehenden LL13-Reports im Designer von LL15 keines der Felder und Variablen mehr findet, die im Delphicode festgelegt wurden. Hat bisher bei den Upgrads aber immer problemlos funktoniert.

Ideen?

LG
Matthias


(Guest) #2

Wau, das klingt mal echt komisch…Also die Variablenlisten weisen keine der
selbst angemeldeten Variablen und Felder im Designer auf?
Wie werden denn die Variablen und Felder an LL angemeldet?

“Matthias Grün” <e-matt@g…> schrieb im Newsbeitrag
news:1114939201017729@combit.net

Hallo!

ich bin gerade von LL13 auf LL15 umgestiegen, in Kombination mit Delphi
2010.

Leider habe ich das Problem, dass er beim Öffnen von bestehenden
LL13-Reports im Designer von LL15 keines der Felder und Variablen mehr
findet, die im Delphicode festgelegt wurden. Hat bisher bei den Upgrads
aber immer problemlos funktoniert.

Ideen?

LG
Matthias


(Guest) #3

Danke für den Denkanstoß. Problem gefunden. Lag nicht am LL13 -> LL15 Upgrade, sondern am Delphi 2007 -> Delphi 2010 Upgrade, das parallel durchgeführt wurde. Ich ermittle die zu übergebenden Variablen an LL mittels Reflection, und da hat sich der String-Datentyp in Delphi 2010 geändert, da jetzt standardmäßig Unicode.

Wau, das klingt mal echt komisch…Also die Variablenlisten weisen keine der
selbst angemeldeten Variablen und Felder im Designer auf?
Wie werden denn die Variablen und Felder an LL angemeldet?

“Matthias Grün” <e-matt@g…> schrieb im Newsbeitrag
news:1114939201017729@combit.net

Hallo!

ich bin gerade von LL13 auf LL15 umgestiegen, in Kombination mit Delphi
2010.

Leider habe ich das Problem, dass er beim Öffnen von bestehenden
LL13-Reports im Designer von LL15 keines der Felder und Variablen mehr
findet, die im Delphicode festgelegt wurden. Hat bisher bei den Upgrads
aber immer problemlos funktoniert.

Ideen?

LG
Matthias