+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

LL13: RTF-Feld und Tabelle


(Guest) #1

Hallo zusammen,

wir haben RTF-Texte in einer Datenbank Spalte (Long-Spalte) und möchten
diese auf einem Report in einem Feld, welches als RTF deklariert ist,
andrucken.

Das funktioniert auch in der Regel soweit ganz gut. Allerdings wenn eine
Tabelle im RTF enthalten ist, dann wird nur die erste Zeile der Tabelle
korrekt gedruckt. Und ab der 2. Zeile wird dann der gesamte “codiert” RTF
Text gedruckt. D.h. ab da steht dann sowas wie “{\rtf1\ansi\ansicpg1252\
…” auf dem Report.

Weiß vielleicht jemand, woran das liegt?

Danke u. viele Grüße, Stefan


(Guest) #2

Ich habe gerade festgestellt, dass dieser Fehler nur unter Vista auftritt
… wenn ich den gleichen Druck unter Windows XP (SP2) starte, dann sieht
alles korrekt aus.

Gruß - Stefan

“Stefan Heisters” <stefan.heisters@w…> schrieb im Newsbeitrag
news:73409222008103923@combit.net

Hallo zusammen,

wir haben RTF-Texte in einer Datenbank Spalte (Long-Spalte) und möchten
diese auf einem Report in einem Feld, welches als RTF deklariert ist,
andrucken.

Das funktioniert auch in der Regel soweit ganz gut. Allerdings wenn eine
Tabelle im RTF enthalten ist, dann wird nur die erste Zeile der Tabelle
korrekt gedruckt. Und ab der 2. Zeile wird dann der gesamte “codiert” RTF
Text gedruckt. D.h. ab da steht dann sowas wie “{\rtf1\ansi\ansicpg1252\
…” auf dem Report.

Weiß vielleicht jemand, woran das liegt?

Danke u. viele Grüße, Stefan