VCL component, IncrementalPreview activated and preview window not modal

Recently I upgraded from version 17 to 27 an original project made with version 10. I had an issue when previewing a report with Zoom greater than 100 because the page appeared centred and I was given as a solution to activate IncrementalPreview. That effectively resolved the previewing issue but now the preview window shows not modal and for me that is mandatory. After a lot of unsuccessful tests I ask for help.

I use the VCL component and the normal loop for previewing.

With IncrementalPreview disabled:

LL->IncrementalPreview= 0;
LL->PreviewAppearance->ZoomPerc= 150;
LL->LlPrintStart(LL_PRINT_PREVIEW);
DefineVars();
LL->LlPrint();
for 1 to n
DefineFields(LL);
while (LL->LlPrintFields()== LL_WRN_REPEAT_DATA)
LL->LlPrint();
LL->LlPrintEnd(0)
LL->LlPreviewDisplay(HANDLE); // ** here report preview shows in modal mode but document is centred in screen: zoom is a problem.

With IncrementalPreview activated:

LL->IncrementalPreview= 1;
LL->PreviewAppearance->ZoomPerc= 150;
LL->LlPrintStart(LL_PRINT_PREVIEW);
DefineVars();
LL->LlPrint(); // here Report preview shows without any data
for 1 to n
DefineFields(LL);
while (LL->LlPrintFields()== LL_WRN_REPEAT_DATA)
LL->LlPrint(); // program flow never enters this point!!!
LL->LlPrintEnd(0) // at this point report preview shows in NOT Modal mode (here Zoom is a NOT a problem). Program flow stops at this point but I can access to the calling window, change parameters, try to preview another report (gets an exception), etc. Program flow continues when I close the preview.

LL->LlPreviewDisplay(HANDLE); // this does nothing

I would need please a hint or guideline.
Thank you very much for your support.

Dear Edorta,
we’ll take a look at the behavior and write to you as soon as we have more information on this, thank you.

Thank you very much Erdal !

Hi Edorta,

we can’t reproduce the behavior like this, I used your code and our LL27 (current Service Pack 27.002) PrintLoop example to test it, as you can see in the screenshot, the zoom is set correctly to 150.

If you get a different result or if this is a different problem, I would ask you to open a support case.
Could you please then adapt the PrintLoop example from us so that we can reproduce the behavior, a description of what is happening and what is expected would also be very helpful.
Of course you can also upload your own example in the support case, thank you very much.

Erdal, thank you for your answer.
I can see in your example that IncrementalPreview is set to 0 and, as the Zoom is greater than 100%, the page appears centred in the screen instead of showing the top part of it. This is the problem I originally had, as stated in Report preview centred in screen and zoom greater than 100% - English Forum - combit Reporting Forum .
The solution given to me was to set IncrementalPreview to 1, and that effectively solved that problem, as in the preview window would appear the top of the page. But setting IncrementalPreview to 1 made my preview window not modal and it being modal is mandatory for me.
So, the problem I am facing is how to make the preview window modal while setting IncrementalPreview to 1. Probably there is something I’m doing wrong, as I originally developed my project with version 10 and there was no IncrementalPreview then. Otherwise tell me if I should open a support case in order to correct the previewing of the report so it does not appear centred with IncrementalPreview set to zero.
Thanks again for your help.

Hi Edorta,
ok sorry, I was misunderstanding this.
Would it be possible to use LlPrintWithBoxStart()?
In my test with LlPrintWithBoxStart I could set LL.IncrementalPreview := 1; i could set the zoom and get the result as you want.
The zoom is in the upper area, the preview is modal as desired.

If you can only use LlPrintStart(…), I would ask them to open a support case and there we will look at the behavior again, thank you.

It works like a charm.
Thank you very much again, Erdal.

© combit GmbH