+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

überflüssiges Aufzählungszeichen bei RTF-Text im Ausdruck vorhanden


(Guest) #1

Bei Übergabe eines RTF-Textes mit einem Aufzählungszeichen ist im Ausdruck ein
überflüssiges Aufzählungszeichen vorhanden,

also z.B… Aufzählung (. 1234) :

string fieldContent = @"{\rtf1\ANSI\ANSICPG1252\DEFF0\DEFLANG1031{\FONTTBL{\F0\FNIL\FCHARSET0 ARIAL;}{\F1\FNIL\FCHARSET2 SYMBOL;}}
\VIEWKIND4\UC1\PARD{\PNTEXT\F1’B7\TAB}{*\PN\PNLVLBLT\PNF1\PNINDENT0{\PNTXTB’B7}}\F0\FS20 1234\PAR
}
";

this.Fields.Add(“MeinRTFFeld”, fieldContent, LlFieldType.RTF);

erzeugt im Ausdruck:

. 1234
.

Hat hier jemand einen Lösungsvorschlag?


(Guest) #2

Versuch mal die Option ‘LL_OPTION_SKIPRETURNATENDOFRTF’ - sollte auch in der Prog-Referenz stehen.


(Guest) #3

Hallo Oliver,
this.Core.LlSetOption(LlOption.SkipReturnAtEndOfRtf, 1);
hatte leider keinen Erfolg, der Effekt tritt nach wie vor auf.


(Guest) #4

Im Header-File gibt es noch diese ‘erweiterte’ Variante:

#define LL_OPTION_ENHANCED_SKIPRETURNATENDOFRTF (171) /* default: false. */

Mal die hier versuchen:
this.Core.LlSetOption(171, 1);

Vielleicht hilft die ja?


(Guest) #5

super !!!
Das war die Lösung.
Das überflüssige Aufzählungszeichen ist jetzt weg im Ausdruck.
Vielen Dank !!