Thumbnails in Preview fehlerhaft

Hallo,
Wir haben für unsere Kunden eine Druckerengine mit LL25 entwickelt. Hier bieten wir über einen Wizard
auch eine Preview Funktion:
llview25.exe “tmpfile”.
Auf allen Entwicklungsrechnern funktioniert das Tool korrekt.
Bei einem Kunden werden links die thumbnails nur als Nummern (1,2,3 etc.) angezeigt. Der Preview selber ist auch korrekt.
Gibt es diesbezüglich Abhängigkeiten gegenüber den Einstellungen und evtl. anderen Installationen
von Windows 10?
Die zur runtime verwendeten binaries sind identisch.

Hallo Herr Hilkmann,

etwaige Abhängigkeiten oder mögliche Beeinflussungen sind uns nicht bekannt solange der Standalone-Viewer entsprechend redistributiert wurde.

Könnten Sie uns einen Screenshot hochladen, mit welchem wir uns das Verhalten in erster Instanz genauer ansehen können?

Besten Dank! :slight_smile:

Hallo,
ich hoffe mal der upload klappt…

grafik

Das Redistributieren läuft wie folgt.

  • beim Kunden werden alle erforderlichen binaries abgelegt
  • zum generieren des Previews verwenden wir unsere Entwickler Lizenz
    .

In der Registry werden unter HKEY_CURRENT_USER\SOFTWARE\combit\cmbtll\LLVIEW25 sowie Computer\HKEY_CURRENT_USER\SOFTWARE\combit\cmbtls\LLVIEW25 Anzeigeeinstellungen abgespeichert. Vielleicht sind hierbei “krumme” Werte reingekommen. Was passiert, wenn Sie LLVIEW25 in diesem Zweigen umbenennen?

Hallo,
ein Umbenennen der registry section, wie oben beschrieben, brachte leider keine Änderung.

Hmm… das ist dann vielleicht doch ein Thema, welches wir genauer in einem Support-Case bearbeiten sollten.

Würden Sie hierzu einen neuen Case anlegen und uns noch die folgenden Fragen beantworten?

1.) Ist lediglich eine Vorschaudatei betroffen oder kann das Verhalten bei mehreren/allen Vorschaudateien beobachtet werden?
2.) Welcher Standarddrucker ist auf dem betroffenem System installiert?
3.) Ändert sich etwas an den kleinen Vorschaubildern, wenn man aktiv etwas an der Breite des Objektrahmens verstellt? Dies sollte ein erneutes Darstellen der Inhalte auslösen und eventuell ein initiales Problem beheben.
4.) Wäre es möglich, dass Sie uns eine Log-Datei vom Erstellen der Vorschau bis zum Anzeigen der Vorschau erstellen?
5.) Ist das Verhalten auch in der aktuellen Version (List & Label 26) nachstellbar?

Vielen Dank für Ihre Mühe und Mitarbeit! :slight_smile:

Punkt 3 brachte die Lösung.
Wird die Breite der Thumbs mit dem Splitter einmalig gegenüber dem Default gewechselt,
funktioniert es immer :slight_smile:

Klasse, dass es so funktioniert hat. Falls das Problem nochmals auftreten sollte und keine einfache Lösung möglich ist, freuen wir uns aber über die Neuanlage eines Support-Cases :slight_smile:

© combit GmbH