+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Tabelle oder Feld?


(Bernd Riemke) #1

Hallo zusammen!

Ich habe eine Tabelle innerhalb von List&Label angelegt und mit Daten gefüllt…
Die Tabelle lässt sich auch mit z.B. “Artikel.Nummer” ansprechen…
Das Feld ist numerisch angelegt…
Innerhalb der Tabelle funktioniert auch alles so weit…
So weit so gut…
Jetzt mein Problem:
Ich kann dieses Feld NICHT mit FStr$ Formatieren, L&L behauptet es handelt sich um einen Text!?

Weiteres kleines Problem:
Ich kann die Tabelle nirgends sehen im Gegensatz zu den Variablen…
Die Tabelle erscheint auch nicht bei den Feldern!?
Wie kann ich die Tabelle sichtbar machen?

Was ist falsch?


(Bernd Riemke) #2

Da stimmt irgend etwas nicht…
Die Tabelle ist im Assistenten zu sehen aber nicht im Designer???


(combit Support - Patrick Preuschoff) #3

Hallo Herr Riemke,

vielen Dank für Ihren Beitrag.

Leider ist eine Analyse ohne weitere Informationen bzw. Dateien recht schwierig. Ich möchte Sie daher auf die bestehenden Programmierbeispiele verweisen, welche Sie im Installationsverzeichnis Ihrer List & Label Installation finden können, in denen Ihnen gezeigt wird wie die Anbindung von Daten am besten realisiert werden kann.

Mit freundlichen Grüßen

Patrick Preuschoff
Technischer Support
combit GmbH


(Bernd Riemke) #4

Sehr geehrter Herr Preuschoff,
es funktioniert ja alles soweit inkl. Ausgabe etc.
Bis eben das anzeigen im Designer…
Da nützen die Beispiele wenig…
Was muss passieren damit eine Tabelle im Designer angezeigt werden kann?
Welcher Befehl sorgt dafür das die TABELLE angezeigt wird?
Mit “LlDbAddTable” ist die Tabelle vorhanden sonst könnte keine Druckausgabe gemacht werden…
Die Daten werden auch richtig übergeben…


(Bernd Riemke) #5

Eine weiter Frage…
Muss bei “AddTable…” eine SQL Datenbank im Hintergrund sein damit der Designer diese anzeigen kann?
Oder ist der Datenquelle egal?


(Bernd Riemke) #6

Hab den Fehler gefunden…
Lag beim “LlDefineFieldExt” da war ein Parameter falsch…