+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Speichen als.. in Vorschau Schalterleiste


(Guest) #1

Hallo
in der LL15 Vorschau ist oben die Schalterleiste sichtbar und auch aktiv. Senden, drucken alles geht - nur “speichern als” funktioniert nicht wie erwartet. Button lässt sich per Maus anklicken, kriegt auch den Fokus. Was fehlt, d.h. nicht erscheint, ist der Dialog zur Auswahl des Dateityps und des Speicherortes.

Was fehlt bei mir für eine Einstellung? Hab pLL->LlPrintSetOptionString( LL_OPTIONSTR_SAVEAS_PATH,“c:\Save”) gesetzt. Ordner ist vorhanden.

Danke für eine Idee.
Stefan


(Guest) #2

Hallo Stefan,

mit genau demselben Problem habe ich mich schon vor zwei Jahren herumgeärgert (damals noch LL12), und ich habe bis heute keine Lösung gefunden (heute LL15). Ich hatte damals weiter geforscht und dabei die folgende Merkwürdigkeit festgestellt (ich würde es wohl eher als Bug bezeichnen):

Der “SpeichernAls”-Dialog wird in der Vorschau nur dann angezeigt, wenn vorher der Listenauswahl-Dialog angezeigt wurde. Bei mir ist dieser Dialog standardmäßig unterdrückt (da ich im Vorfeld ja weiß, was ich ausgeben will, und nicht erst noch den Anwender damit belästigen muss). Lasse ich den Dialog vorher anzeigen, kann ich auch speichern.

Meines Erachtens macht dieser Zusammenhang absolut keinen Sinn. Es muss ja wohl möglich sein, das Ergebnis einer Druckausgabe zu speichern, ohne dass ich vorher eine überflüssige Auswahl treffen muss. Laden und Speichern sind eindeutig zwei Paar Stiefel!

Wenn dafür jemand noch einen Workaround bieten könnte wäre ich ebenfalls extrem dankbar. Mein Versuch mit
“LlPrintSetProjectParameter(‘SaveAs.ShowDialog’,‘1’,LL_PARAMETERFLAG_VALUE)” hat mich auf jeden Fall nicht weitergebracht, da dieser Parameter offensichtlich beim Start des Previews übersteuert wird.

Viele Grüße
Hans-Peter


(Guest) #3

Das kann ich so nicht bestätigen. Ich verwende .NET und habe da AutoDesignerFile gesetzt und AutoShowFileSelect auf false. Dennoch kann ich in der Vorschau speichern. Das wäre auch wirklich eher unerwartet. Hast Du da schonmal combit gefragt?


(Guest) #4

Bei uns kommt auch .Net zum Einsatz und dort funktioniert es tadellos - zumindest bisher. Ich hatte mir auch kurz die Mühe gemacht es mal weiter zu probieren:

LL.AutoShowSelectFile = false;
LL.AutoShowPrintOptions = false;
LL.AutoProjectType = LlProject.List;
LL.AutoDestination = LlPrintMode.Preview;
LL.AutoDesignerFile = @“C:\test\testReport.lst”;
LL.Core.LlSetOptionString(LlOptionString.SaveAs_Path, @“c:\test\outputFile”)

Und damit hatte es aber auch funktioniert. Vielleicht wirklich mal die combit Mannschaft fragen?


(Guest) #5

Zu diesem Problem hatte ich damals schon einen Thread eröffnet, man findet ihn hier.

Es][/url] kann ja sein, dass es mit .Net funktioniert. Ich arbeite allerdings mit den VCL-Komponenten, und da gibt es den beschriebenen Effekt. Stefan, womit arbeitest du?


(Guest) #6

Hallo Leute

Hab’s bei mir lösen können. Arbeite mit VCL LL15.

Deim Previewaufruf wir der Dateiname der ll Datei inkl Pfad übergeben .
Die Angaben des Pfades im Dateinamen hatten bei mir Slash’s.
Werden alle Slash’s durch Backslash’s ersetzt, dann startet
der “Speichern als” Dialog bei mir.

Danke für Eure Postings.

Geh jetzt zu einem Bier :slight_smile:

Stefan