+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Russisches Formular


(Guest) #1

Hallo zusammen!

Ich benutze die LL Version 12 Professional Edition (Unicode fähig soweit ich weiß) und möchte ein Russisches Formular erstellen!
Bei rtf-Felder zeigt mir der Designer die russischen Zeichen wunderbar an, aber sobald ich eine Formel hinterlege:

z.B. if(strArt = ‘rechnung’, “Счет №”)
(deutsch) if(strArt = ‘rechnung’, “Rechnung Nr.:”)

wird statt dem “Счет №” -> “???” angezeigt!

Weiß jemand wie ich das um- bzw. einstellen kann?

Über eine Antwort würde ich mich sehr freuen!

Gruß Christopher


(Guest) #2

Welche DLL verwendest Du? CMLL12 oder CULL12?

Tip: Wenn Du’s Dir leisten kannst, nimm die CULL12. Dann sind
allerdings Win9x und ME out, aber Du bist die Zeichensatzprobleme los.

Paulchen

“Christopher Vetterl” <christopher.Vetterl@wolfsyst…> wrote in
message news:117811212008141337@combit.net

Hallo zusammen!

Ich benutze die LL Version 12 Professional Edition (Unicode fähig
soweit ich weiß) und möchte ein Russisches Formular erstellen!
Bei rtf-Felder zeigt mir der Designer die russischen Zeichen
wunderbar an, aber sobald ich eine Formel hinterlege:

z.B. if(strArt = ‘rechnung’, “Счет №”)
(deutsch) if(strArt = ‘rechnung’, “Rechnung Nr.:”)

wird statt dem “Счет №” -> “???”
angezeigt!

Weiß jemand wie ich das um- bzw. einstellen kann?

Über eine Antwort würde ich mich sehr freuen!

Gruß Christopher


(Guest) #3

Danke für deine Antwort!

In allen meinen bisherigen projekten hab ich die CMLL12 verwendet!
von der CULL12 hab ich der Hilfe gelesen und habe es daraufhin ausprobiert! sieht so aus als hätte ich sie falsch eingebunden bzw verlinkt!
Hab beide gleichzeitig verwendet, geht das?! oder nur eine von beiden?

PS:Win9x und ME wird in der Firma nicht mehr verwendet bzw ME noch nie :wink:

Gruß Christopher

Welche DLL verwendest Du? CMLL12 oder CULL12?

Tip: Wenn Du’s Dir leisten kannst, nimm die CULL12. Dann sind
allerdings Win9x und ME out, aber Du bist die Zeichensatzprobleme los.

Paulchen

“Christopher Vetterl” <christopher.Vetterl@wolfsyst…> wrote in
message news:117811212008141337@combit.net

Hallo zusammen!

Ich benutze die LL Version 12 Professional Edition (Unicode fähig
soweit ich weiß) und möchte ein Russisches Formular erstellen!
Bei rtf-Felder zeigt mir der Designer die russischen Zeichen
wunderbar an, aber sobald ich eine Formel hinterlege:

z.B. if(strArt = ‘rechnung’, “Счет №”)
(deutsch) if(strArt = ‘rechnung’, “Rechnung Nr.:”)

wird statt dem “Счет №” -> “???”
angezeigt!

Weiß jemand wie ich das um- bzw. einstellen kann?

Über eine Antwort würde ich mich sehr freuen!

Gruß Christopher


(Guest) #4

Vielen Dank, ich habs geschafft!
die CMLL12 gehört durch die CULL12 ersetzt, zusammen funktioniert es nicht!

Danke nochmal!

Gruß Christopher

Welche DLL verwendest Du? CMLL12 oder CULL12?

Tip: Wenn Du’s Dir leisten kannst, nimm die CULL12. Dann sind
allerdings Win9x und ME out, aber Du bist die Zeichensatzprobleme los.

Paulchen

“Christopher Vetterl” <christopher.Vetterl@wolfsyst…> wrote in
message news:117811212008141337@combit.net

Hallo zusammen!

Ich benutze die LL Version 12 Professional Edition (Unicode fähig
soweit ich weiß) und möchte ein Russisches Formular erstellen!
Bei rtf-Felder zeigt mir der Designer die russischen Zeichen
wunderbar an, aber sobald ich eine Formel hinterlege:

z.B. if(strArt = ‘rechnung’, “Счет №”)
(deutsch) if(strArt = ‘rechnung’, “Rechnung Nr.:”)

wird statt dem “Счет №” -> “???”
angezeigt!

Weiß jemand wie ich das um- bzw. einstellen kann?

Über eine Antwort würde ich mich sehr freuen!

Gruß Christopher


(Guest) #5

Hab mich zu früh gefreut es geht leider doch noch nicht alles!
ich habe immernoch ein Problem mit den Formeln!

Im Dialog wo ich die Formel erstelle, steht ja links unten das “Ergebnis”! dort steht es jetzt richtig in Russischer Schrift (war vorher nicht so, es kamen “???”), aber sobald ich auf OK klicke zeigt er mir im Designer wieder “???” an! wenn ich wieder in die Formel reingehe steht immernoch der Russische Text drinnen, in der vorherigen Version mit der cmll12 wurde der wieder durch “???” ersetzt!

auch in der Vorschau funktioniert es nicht?!

Wäre super wenn ihr eine Antwort wüsstet! :smiley:

Gruß Christopher

Hallo zusammen!

Ich benutze die LL Version 12 Professional Edition (Unicode fähig soweit ich weiß) und möchte ein Russisches Formular erstellen!
Bei rtf-Felder zeigt mir der Designer die russischen Zeichen wunderbar an, aber sobald ich eine Formel hinterlege:

z.B. if(strArt = ‘rechnung’, “Счет №”)
(deutsch) if(strArt = ‘rechnung’, “Rechnung Nr.:”)

wird statt dem “Счет №” -> “???” angezeigt!

Weiß jemand wie ich das um- bzw. einstellen kann?

Über eine Antwort würde ich mich sehr freuen!

Gruß Christopher


(Guest) #6

Hast Du einen Font ausgewählt, der russische Zeichen unterstützt?

Paulchen

Im Dialog wo ich die Formel erstelle, steht ja links unten das
“Ergebnis”! dort steht es jetzt richtig in Russischer Schrift (war
vorher nicht so, es kamen “???”), aber sobald ich auf OK klicke
zeigt er mir im Designer wieder “???” an! wenn ich wieder in die
Formel reingehe steht immernoch der Russische Text drinnen, in der
vorherigen Version mit der cmll12 wurde der wieder durch “???”
ersetzt!

auch in der Vorschau funktioniert es nicht?!

Wäre super wenn ihr eine Antwort wüsstet! :smiley:


(Guest) #7

Arial!?!?!
keine ahnung ob der Font das kann! kann ihn zumindest auf kyrillisch stellen!

komischerweise geht es nur nicht wenn ich in Rtf-Felder Formeln hinterlege bei normalen Feldern mit Formeln schon!
Hab jetzt alle Rtf-Felder auf normale Felder umgestellt und jetzt funktioniert es!

Danke für deine Hilfe!

Gruß Christopher

Hast Du einen Font ausgewählt, der russische Zeichen unterstützt?

Paulchen

Im Dialog wo ich die Formel erstelle, steht ja links unten das
“Ergebnis”! dort steht es jetzt richtig in Russischer Schrift (war
vorher nicht so, es kamen “???”), aber sobald ich auf OK klicke
zeigt er mir im Designer wieder “???” an! wenn ich wieder in die
Formel reingehe steht immernoch der Russische Text drinnen, in der
vorherigen Version mit der cmll12 wurde der wieder durch “???”
ersetzt!

auch in der Vorschau funktioniert es nicht?!

Wäre super wenn ihr eine Antwort wüsstet! :smiley: