+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Query on save after editing form controls in preview

I have in LST form controls. When I change a control in preview and then I will it close, LL display message “You have changed some of the values in the file. Do you want to save the changes?” Can I somehow suppress these message? Thanks.

Hi Martin,

Check out chapter 8.4.4. “Automatic Storage of Form Data”. You’re looking for “SaveAs.NoSaveQuery”.

HTH
G.

Hi
I was advised to use “SaveAs.NoSaveQuery”. So I used this command: LlPrintSetProjectParameter (hJob, “SaveAs.NoSaveQuery”, “1”, LL_PARAMETERFLAG_VALUE)
Then there is no message “You have changed some of the values…”, but a “Save as…” dialog has appeared.
When I use command LlPrintSetProjectParameter (hJob, “SaveAs.ShowDialog”, “0”, LL_PARAMETERFLAG_VALUE)
a “Save as…” appeared anyway, so I had to use these commands: LlPrintSetProjectParameter (hJob, “SaveAs.Format”,“LL”, LL_PARAMETERFLAG_VALUE); LlPrintSetProjectParameter (hJob, “SaveAs.Filename”, “mytemp.LL”, LL_PARAMETERFLAG_VALUE); After this it works without asking “Save as…”, but Windows are trying to open the saved file (“mytemp.LL”).
I suppose this is because there is a “Open the application assigned to the file after saving” option ON.
So my questions are:
a) Solution 1: What can I do to not open the saved file? (set programmaticaly “Open the application assigned to the file after saving” option OFF)
b) Better solution 2: Is there any possibility of closing preview without any query and WITHOUT SAVING ANY FILE?
Thank you.

Dear Martin,
thank you for your post.

a)
You can use the “Export.ShowResult” export option to not show the saved file e.g.
LlXSetParameter(hJob, LL_LLX_EXTENSIONTYPE_EXPORT, “PRV”, “Export.ShowResult”, “0”);
b)
Sorry there is no possibility for this. You have to save a file (after saving you can delete it).

Kind regards

Erdal Alacali
Technical support
combit GmbH

© combit GmbH