Projektbaustein immer drucken / ausgeben

Hallo Zusammen,

ich arbeite mich gerade als Quereinsteiger in der IT in die Reporterstellung mit List&Label ein. Aktuell arbeite ich daran über die Projektbausteine einheitliche Kopfzeilen oder Fußzeilen in bestehende Dokumente einzubauen.

In meinem aktuellen Problem versuche ich nun ein Firmenlogo und zwei Vorgangsnummern über den Baustein einzufügen, um Änderungen des Logos nur noch zentral in dem Projektbaustein zu tätigen. Das hat auch geklappt, allerdings wird bei der Druckausgabe genau dieser Baustein nicht mit ausgegeben.

Ich habe schon im Forum und im Handbuch gelesen, dass man auf bestimmte Objekte mit den Bedingungen die Druckausgabe steuern kann. Leider finde ich es nicht, wo ich das einstellen kann.

Vielen Dank für die Hilfe!

Hi willkommen im List & Label Dschungel :smile:

Du findest die Darstellungsbedingung in den Eigenschaften der Objekte, dort kann man dann eine Formel hinterlegen.


Komisch… diese Einstellungen habe ich auch so drinnen:

Kann das mit der Einbettung der Datei zusammenhängen?

Hallo,

bitte überprüfen Sie im Hauptprojekt mal die Darstellungsbedingung des Bausteins (über Projekt > Bausteine):

Ich hab ihnen ein kleines Sample mit einem Baustein für die Demo Applikation angehängt:

Hauptprojekt.lsr (39.3 KB)
Bausteinprojekt.lsr (8.9 KB)

Bitte kopieren Sie beide Projekte in das selbe Verzeichnis. Das Hauptprojekt können Sie mit Hilfe unserer Demo Applikation “DemoApplication28.exe” im Unterverzeichnis “Beispielanwendung”, über “Berichte” öffnen.

Das combit Logo kommt hier aus dem Bausteinprojekt. Wenn Sie im Designer den Reiter “Vorschau” betätigen, wird das Logo angezeigt?

Hallo Herr @oboyaci ,

Danke für den Hinweis, hier hatte ich vorab auch schon die Einstellungen überprüft. Diese sind komplett identisch mit Ihren. Auf den Ebenen sind auch keine Bedingungen hinterlegt:

Muss ich an dieser Stelle in den allgemeinen Einstellungen etwas ändern? Liegt hier vielleicht mein Fehler?
image

In meiner Projekt-Vorschau in LL wird alles korrekt auf die drei Seiten eingefügt und angezeigt.

Die Einstellungen sollten hier kein Problem darstellen. Daher folgende Bitte:

Öffnen Sie die oben angehängten Projektdateien in der Demo Applikation, und übernehmen Sie jede Einstellung aus Ihrem Projekt darin, bis das beschriebene Verhalten auch in diesem Projekt nachvollzogen werden kann. Laden Sie dann die “kaputten” Projektdateien wieder hier hoch. Wir schauen uns das Verhalten dann näher an.

Vielen Dank.

Wie ich das lese ist es in der Designer Echtdatenvorschau korrekt und nur beim Druck wird der Baustein nicht korrekt angezeigt bzw. gedruckt?
Mal prüfen ob hier wirklich auch das gleiche Projekt verwendet wird, passiert manchmal das man unterschiedliche Projekte (Design vs Druck) hat.

Ich habe den Fehler inzwischen gefunden. Ich haben den Baustein noch nicht auf einem zentralen Laufwerk abgelegt gehabt, sondern auf meinem persönlichen Laufwerk. So konnte wohl nicht auf die Daten zugegriffen werden. Mit dem zentralen Speicherort funktioniert es einwandfrei! :smiling_face:

2 Likes

kleiner Tipp, wenn du debwin4 aus dem combit Installationsordner ausführst und LL loggst, würdest du direkt sehen das der Baustein nicht geladen werden kann, hier ein Link mit weiteren Infos zu dem combit debugg tool.

1 Like

© combit GmbH