+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Outlook 2007/2010: Signatur wird bei Versand aus Vorschau nicht angehängt


(Guest) #1

Hallo NG,

wenn ich aus der List&Label 15 Vorschau heraus die Mailfunktion aufrufe (Anhang als PDF) wird eine neue Mail erzeugt (Outlook 2007 oder 2010,) die hinterlegte Signatur (keine digitale Signatur, sondern die in Outlook eingetragenen Absenderzeilen) wird jedoch nicht in die Mail übernommen. In Outlook ist die Signatur so eingerichtet, das sie automatisch beim Verfassen und Weiterleiten von Mails angehängt werden soll.
In Outlook Express und Thunderbird klappt das.
Ist das ein Problem, das in List&Label gelöst werden kann, oder liegt’s an Microsoft Office?

Danke für Tipps,

Ingo


(Guest) #2

Hallo Ingo,

ist ganz einfach: Schau mal im Programmierer-Handbuch auf Seite 369 nach. Du
verwendest die Simple MAPI, damit aber die Signatur eingesetzt werden kann,
muss Extended MAPI verwendet werden. Also bei Export.Mail.Provider einfach
XMAPI setzen.

Viel Erfolg

Mike

“Ingo Kothke” <lul@koth…> schrieb im Newsbeitrag
news:470357192010182510@combit.net

Hallo NG,

wenn ich aus der List&Label 15 Vorschau heraus die Mailfunktion aufrufe
(Anhang als PDF) wird eine neue Mail erzeugt (Outlook 2007 oder 2010,) die
hinterlegte Signatur (keine digitale Signatur, sondern die in Outlook
eingetragenen Absenderzeilen) wird jedoch nicht in die Mail übernommen. In
Outlook ist die Signatur so eingerichtet, das sie automatisch beim
Verfassen und Weiterleiten von Mails angehängt werden soll.
In Outlook Express und Thunderbird klappt das.
Ist das ein Problem, das in List&Label gelöst werden kann, oder liegt’s an
Microsoft Office?

Danke für Tipps,

Ingo


(Guest) #3

Hi Mike,

danke für den Tipp aber:

  • diese Einstellung hatte ich so verstanden, dass sie für den (automatischen) Versand als Mail verwendet werden sollte? Mir geht es um den Versand aus dem Vorschaufenster heraus.)
  • wenn ich die Parameter setze, öffnet sich nicht Outlook, sondern ein recht spatanischer Mail-Client (der unter Systemsteuerung / Combit Maileinstellungen als Standard gesetzt werden konnte - jedenfalls vor Windows 7; unter Win7 finde ich das Modul nicht mal.)

War’s ein Missverständnis, oder mache ich was falsch?

Schönen Gruß,

Ingo

Hallo Ingo,

ist ganz einfach: Schau mal im Programmierer-Handbuch auf Seite 369 nach. Du
verwendest die Simple MAPI, damit aber die Signatur eingesetzt werden kann,
muss Extended MAPI verwendet werden. Also bei Export.Mail.Provider einfach
XMAPI setzen.

Viel Erfolg

Mike


(Guest) #4

Es ist bei MAPI wohl nicht möglich, dem bestehenden Body einen zusätzlichen Text zu übergeben. L&L übergibt an den Body offenbar grundsätzlich etwas – auch wenn es nichts ist – und überschreibt somit den vorhandenen Body. Darum fliegt auch bei MS Outlook die Signatur raus. Du kannst hier leider nichts ändern. Wenn, dann müsste combit den oben genannten Umstand ändern.

Bei einigen anderen Mailprogrammen scheint es anders gelöst zu sein. Bei Thunderbird scheint die Signatur irgendwie noch nachträglich eingefügt zu werden.


(Guest) #5

Da kann Combit aber nichts für, das ist ein Problem von Outlook / MAPI.
Selbst wenn du dich selbst um die E-Mailfunktion kümmerst (über MAPI), also MAPI selbst aufrufst, dann wird das nicht klappen. Sobald Outlook über MAPI angesprochen wird, übergibt Outlook keine Signatur mehr.

Einzige Möglichkeit, die dir bleibt: du musst dich selbst um den E-Mailversand kümmern, also PDF-Datei quiet irgendwo abspeichern und deinen MAPI-Client selbst aufrufen. Dabei musst du dann dem Body eine hinterlegte “Signatur” übergeben. Eventuell kann man die Outlook-Signatur auch irgendwo auslesen… Musst du mal schauen…
So ähnlich haben wir es hier nämlich auch machen müssen.


(Guest) #6

Da kann Combit aber nichts für, das ist ein Problem von Outlook / MAPI.
<<<

Stimmt. Ich bin davon ausgegangen, dass es sich bei MAPI ähnlich wie beim Aufruf per ShellExecute verhält. Hier bleibt die Signatur erhalten, wenn man keinen Body-Tag übergibt.