+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Leerzeichen werden nicht bzw falsch beim Kunden dargestellt


(Simon Dadok) #1

Guten Tag,
wir haben ein sehr seltsames Verhalten bzw Problem mit einer Vorlage.

Es wurde eine Visitenkartenvorlage mit diversen Feldern erstellt. Die Werte werden aus der Datenbank in ein eigenes Objekt geladen, welches dann an die Vorlage übergeben wird.

Teilweise sind Leerzeichen in den jeweiligen Strings, wie z.B. “Max Mustermann”.

Dieser Wert wurde so in der DB gespeichert, ausgelesen und an die Vorlage übermittelt.

Bei unseren Kunden werden die Leerzeichen aber nicht vernünftig dargestellt. Es scheint als ob diese sehr viel schmaler bzw gar nicht sichtbar wären.

Es wurde bereits die “Leerzeichenoptimierung” abgestellt. Zudem haben wir auch die Breite der jeweiligen Felder in der Vorlage angepasst.

Hat es evtl etwas mit dem Betriebssystem zu tun? Wir verwenden Windows 10 und der Kunde Windows 7.


(Günther Schwarze) #2

Das kenne ich so nicht. Kannst Du vielleicht mal eine andere Schriftart versuchen? Oder ein anderes Ausgabeformat (PDF oder Vorschau)? Dann wüsstest Du ob es am Drucker(-treiber) oder an was anderem liegt.

G.


(Simon Dadok) #3

Guten Morgen,
folgendes habe ich versucht:

  • Schriftart ausgetauscht -> Keine Besserung.
  • Ausgabeformat im Designer als auch im Source geändert -> Keine Besserung
  • Platzhalter welche in der Vorlage mit Leerzeichen geändert werden -> Keine Besserung

Beim Kunden als auch bei uns wird der PDF-Drucker “PDF-XChange Lite V6” .
verwendet.

In dem Bild sieht man hoffentlich die verschiedenen Breiten der Leerzeichen. Die Werte kommen alle aus der DB. Testweise habe ich versucht sowas einzugeben “Test Wert”. Dann ist das Ergebnis aber das gleiche.

Unbenannt.JPG


(Günther Schwarze) #4

Und was passiert mit dem LL-eigenen PDF-Export? Sieht es da besser aus?


(Simon Dadok) #5

Leider nein.

Es ändert sich rein gar nichts.


(Günther Schwarze) #6

Dann würde mir nur noch einfallen, einmal die PDF-Export-Option ExactPositioning zu aktivieren (geht über die Exportoptionen). Wenn das auch nix hilft musst Du bei combit wohl mal einen Case aufmachen.

G.


(Martin Richter) #7

Mal eine ganz andere Frage.

Die PDF Dateien des Kunden, sehen die auf Eurer Maschine “normal” aus.
Könnte es also eher am Viewer, des Kunden liegen…


(Simon Dadok) #8

Guten Morgen,
das habe ich auch zu Beginn vermutet. Auch dies kann ich leider komplett ausschließen.

Die Texte in der PDF sind zwar richtig positioniert, aber die Leerzeichen passend halt leider nicht -.-