+1 800 256 3608 (toll-free in North America) or +49 7531 9060-10| service@combit.com

Export nach Excel unter Access

Hallo,
seitdem ich auf die neue Version von List und Label umgestiegen bin, werden mir beim Drucken kein Exportformat bei "Ausgabe auf…"nach Excel mehr angezeigt.

Der Aufruf unter Access lautet bei mir wie folgt:
ret% = ListLabel1.Print(0, LL_PROJECT_LIST, “MeinBericht.lst”, 1, LL_PRINT_EXPORT, _
LL_BOXTYPE_NORMALWAIT, hWnd, “Print labels to printer”, True, Environ$(“temp”))

Was mache ich falsch. Oder hat sich etwas geändert.
Wie muss ich den Aufruf starten, dass der Excel-Export wieder angezeigt wird?

Danke vielmals

Viele Grüße
Claus

Hallo Claus,

vielen Dank für Ihren Beitrag.

Wie sieht denn die Liste der verfügbaren Ausgabemedium generell aus? Könnten Sie uns hier einen Screenshot bereitstellen?

Gerne würden wir List & Label in diesem Fall aber auch “unter die Haube” schauen - hierfür wäre eine Log-Datei hilfreich.

Weitere Informationen zur Erstellung einer Log-Datei finden Sie in nachfolgendem Knowledgebase-Artikel:

Auch hinsichtlich des Vorkommens personenbezogener Daten empfehle ich Ihnen einen Support-Case über unser Support-Portal zu erstellen und die beiden Dateien entsprechend hochzuladen. Gerne ergänzen wir diesen Forenthread im Anschluss um weitere Informationen zur Problemlösung.

Hallo Patrick,

Da es sich um Demo-Daten handelt ist es kein Problem.

Anbei die Log-datei und wie die Auswahl aussieht:


Print.log4 (365.2 KB)

Danke schonmal
lg
Claus

Könnten Sie einmal prüfen, ob Sie die Datei cmll25ex.llx mit der Anwendung weitergegeben haben? Im Logfile fehlt leider der Teil mit den geladenen DLLs, der Screenshot wäre aber das typische Symptom. In dieser Datei sind sämtliche Exportformate enthalten (die auf dem Shot alle fehlen).

Okay mache ich, aber ich befinde mich gerade in der Entwicklerumgebung und da tauchen die Exportformate auch nicht auf.

Seltsam ich habe gerade das Log komplett durchgeführt auf dem Entwicklerrechner:

Hallo,
nun habe ich das Setup-Paket mit der CMLL25ex.llx auf einen Testrechner mit ausgeliefert.
Dort funktioniert es nun. Warum es auf dem Entwicklerrechner nicht funktioniert, ist mir nicht ganz klar. Aber ich bin jetzt schonmal froh, dass ich es dem Kunden nun so ausliefern kann.

Liebe Grüße und herzlichen Dank
Claus

Auffällig ist, dass die Dateien aus dem Systemverzeichnis geladen werden. Vielleicht haben Sie noch eine Anwendung eines anderen Herstellers, die ebenfalls List & Label verwendet und einen lückenhaften DLL-Satz dorthin kopiert hat? Sie können entweder den vollen Satz nach system32 kopieren oder die DLLs dort löschen. Anwendungen sollten Dateien grundsätzlich nicht im System-Verzeichnis installieren.

1 Like

© combit GmbH