+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Echtdatenvorschau im Designer


(Guest) #1

Hallo,

was ist eigentlich zu tun, um eine Echtdatenvorschau zu erhalten? Wenn ich mich im Designer bewege, erhalte ich nur die normale Vorschau aus den Vorgängerversionen. Die Einstellung

LlSetOption(LlOption.DesignerPreviewParameter, 1);

habe ich definiert.

Umgebung: .NET 2003, .NET 2008 mit LL14 unter XP SP3

Innerhalb der Beispielanwendung funktioniert die Echtdatenvorschau.

Danke
Steffen Häselbarth


(Guest) #2

“Steffen Häselbarth” <steffen.haeselbarth@kid-magdebu…> schrieb im
Newsbeitrag > was ist eigentlich zu tun, um eine Echtdatenvorschau zu
erhalten?

Mit .NET einfach ein DataSet verwenden, den Rest macht das Databinding
automatisch. Oder einen Blick in das DesignerPreview-Sample und das passende
Handbuchkapitel werfen, da ist der Weg “zu Fuss” beschrieben. Habe ich aber
noch nie selber gemacht, das Databinding reicht fuer meine Zwecke voellig
aus.

G.


(Guest) #3

Mit .NET einfach ein DataSet verwenden, den Rest macht das Databinding
automatisch. Oder einen Blick in das DesignerPreview-Sample und das passende
Handbuchkapitel werfen, da ist der Weg “zu Fuss” beschrieben. Habe ich aber
noch nie selber gemacht, das Databinding reicht fuer meine Zwecke voellig
aus.

Ich habe mich wohl etwas zu sparsam ausgedrückt. Ich übergebe schon ein DataSet an LL. In manchen Berichten drucke ich mittels ListLabel.LlPrint, in anderen mittels ListLabel.Core.LlPrint. Wenn ich dann aber im Designer von “Layout” auf “Vorschau” wechsle, sollte laut combit eine Echtdatenvorschau erscheinen. Bei mir erscheint zwar auch das Vorschaufenster. Aber alle Symbole (Goto First, Goto Prev, Zoom, …) sind ausgegraut, das Inhaltsverzeichnis ist leer und die Seitenvorschau zeigt sich als leeres graues Bild.

Steffen


(Guest) #4

Ich habe mich wohl etwas zu sparsam ausgedrückt. Ich übergebe schon ein
DataSet an LL. In manchen Berichten drucke ich mittels ListLabel.LlPrint,
in anderen mittels ListLabel.Core.LlPrint. Wenn ich dann aber im Designer
von “Layout” auf “Vorschau” wechsle, sollte laut combit eine
Echtdatenvorschau erscheinen. Bei mir erscheint zwar auch das
Vorschaufenster. Aber alle Symbole (Goto First, Goto Prev, Zoom, …) sind
ausgegraut, das Inhaltsverzeichnis ist leer und die Seitenvorschau zeigt
sich als leeres graues Bild.

Hast Du sichergestellt, dass in der Datenquelle auch Daten drin sind, nicht
nur Schema-Informationen? Schau mal das Databinding-Beispiel 2 an, da wird
auch ein DataSet verwendet und da klappt es prima.

G.


(Guest) #5

Hallo,

ich habe da auch erst mal etwas gesucht, bis ich gefunden habe das “EnableCallbacks” auf “false” gesetzt war…nach dem Setzen auf “true” funktionierte es dann sofort tadellos!

Gruß,
Andreas

Ich habe mich wohl etwas zu sparsam ausgedrückt. Ich übergebe schon ein
DataSet an LL. In manchen Berichten drucke ich mittels ListLabel.LlPrint,
in anderen mittels ListLabel.Core.LlPrint. Wenn ich dann aber im Designer
von “Layout” auf “Vorschau” wechsle, sollte laut combit eine
Echtdatenvorschau erscheinen. Bei mir erscheint zwar auch das
Vorschaufenster. Aber alle Symbole (Goto First, Goto Prev, Zoom, …) sind
ausgegraut, das Inhaltsverzeichnis ist leer und die Seitenvorschau zeigt
sich als leeres graues Bild.

Hast Du sichergestellt, dass in der Datenquelle auch Daten drin sind, nicht
nur Schema-Informationen? Schau mal das Databinding-Beispiel 2 an, da wird
auch ein DataSet verwendet und da klappt es prima.

G.


(Guest) #6

Hallo,

Ich habe mich wohl etwas zu sparsam ausgedrückt. Ich übergebe schon ein
DataSet an LL. In manchen Berichten drucke ich mittels ListLabel.LlPrint,
in anderen mittels ListLabel.Core.LlPrint. Wenn ich dann aber im Designer
von “Layout” auf “Vorschau” wechsle, sollte laut combit eine
Echtdatenvorschau erscheinen. Bei mir erscheint zwar auch das
Vorschaufenster. Aber alle Symbole (Goto First, Goto Prev, Zoom, …) sind
ausgegraut, das Inhaltsverzeichnis ist leer und die Seitenvorschau zeigt
sich als leeres graues Bild.

Hast Du sichergestellt, dass in der Datenquelle auch Daten drin sind, nicht
nur Schema-Informationen? Schau mal das Databinding-Beispiel 2 an, da wird
auch ein DataSet verwendet und da klappt es prima.

ja, ich übergebe auch Daten. Diese kann ich im Designer in der Layout-Vorschau auch sehen. Nur die Vorschau bleibt grau und datenlos. In der gelieferten Beispielanwendung kann ich ja die Echtdatenvorschau bestaunen. D.h. ich habe die Hoffnung, dass es bei mir auch bald klappen wird.

Gruß
Steffen


(Guest) #7

Hallo Andreas,

Hallo,

ich habe da auch erst mal etwas gesucht, bis ich gefunden habe das “EnableCallbacks” auf “false” gesetzt war…nach dem Setzen auf “true” funktionierte es dann sofort tadellos!

Gruß,
Andreas

Ich habe mich wohl etwas zu sparsam ausgedrückt. Ich übergebe schon ein
DataSet an LL. In manchen Berichten drucke ich mittels ListLabel.LlPrint,
in anderen mittels ListLabel.Core.LlPrint. Wenn ich dann aber im Designer
von “Layout” auf “Vorschau” wechsle, sollte laut combit eine
Echtdatenvorschau erscheinen. Bei mir erscheint zwar auch das
Vorschaufenster. Aber alle Symbole (Goto First, Goto Prev, Zoom, …) sind
ausgegraut, das Inhaltsverzeichnis ist leer und die Seitenvorschau zeigt
sich als leeres graues Bild.

Hast Du sichergestellt, dass in der Datenquelle auch Daten drin sind, nicht
nur Schema-Informationen? Schau mal das Databinding-Beispiel 2 an, da wird
auch ein DataSet verwendet und da klappt es prima.

G.

danke für den Tipp. Aber “EnableCallbacks” ist schon auf true gesetzt. Ich schau mal, ob das Debugging etwas brauchbares liefert.

Gruß
Steffen