+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Chart wird trotz Wertetabelle nicht angezeigt


(Guest) #1

Hallo, nochmal eine kurze Frage:

Situation:

  • 1 Tabellenobjekt, 1 ChartObjekt (Liniendiagramm)

Vorgehensweise:
Tabellenobjekt wird innerhalb des Codes mit Daten gefüllt.
Insgesamt gibt es mehrere gefüllte Spalten, unter anderem
X (mit den Werten 100,200,300,400,500…900
Y (mit den werten 1.6,2.5,3.9,4.1…,9.7

Im Designermodus habe ich das Chartobjekt erstellt und den jeweiligen
Achsenwerten die zugehörigen Datenfelder (Fields) zugeordnet.
Dort wo die Variablen im Designer angesprochen werden lässt sich
jeweils der zuletzt eingetragene Wert ablesen.

Problem:

Die Charts (der Chart) werden nichtmals ohne Daten angezeigt, das gesamte Objekt ist
in der Druckversion nicht zu sehen.

Sind noch bestimmte Aufrufe im Quelltext zu tätigen, außer der eindeutigen
Zuordnung zwischen den Achsenwerten und den zugehörigen Feldern der Tabelle?

Die Tabelle besitzt 9 Datenzeilen und 9 Spalten, diese sind korrekt gefüllt.
Reicht es nicht aus die gewollte Datenquelle für die Achsenwerte per Formel auf
das der tabellenspalte zugehörige Field zu setzen?


(Guest) #2

Der Chart wird nur dann nicht angezeigt, wenn der Gesamtdruck nur eine Seite umfasst!
Aber warum?

Füge ich soviele Daten in die Tabelle dass sie sich auf eine zweite Seite erstreckt,
erstellt er auf der neuen Seite (2. Seite) die Grafik, allerdings mit den Werten aus der ersten Tabelle (Seite 1).

Beide Objekte liegen in der gleichen Ebene, komischerweise wird der Chart aber erst bei Existenz einer zweiten
Seite auf jener gespeichert.

Dies ist auch bei diversen Beispielprojekten der Fall, sofern kein Berichtscontainer verwendet wird.

Weiß jemand Rat?

Hallo, nochmal eine kurze Frage:

Situation:

  • 1 Tabellenobjekt, 1 ChartObjekt (Liniendiagramm)

Vorgehensweise:
Tabellenobjekt wird innerhalb des Codes mit Daten gefüllt.
Insgesamt gibt es mehrere gefüllte Spalten, unter anderem
X (mit den Werten 100,200,300,400,500…900
Y (mit den werten 1.6,2.5,3.9,4.1…,9.7

Im Designermodus habe ich das Chartobjekt erstellt und den jeweiligen
Achsenwerten die zugehörigen Datenfelder (Fields) zugeordnet.
Dort wo die Variablen im Designer angesprochen werden lässt sich
jeweils der zuletzt eingetragene Wert ablesen.

Problem:

Die Charts (der Chart) werden nichtmals ohne Daten angezeigt, das gesamte Objekt ist
in der Druckversion nicht zu sehen.

Sind noch bestimmte Aufrufe im Quelltext zu tätigen, außer der eindeutigen
Zuordnung zwischen den Achsenwerten und den zugehörigen Feldern der Tabelle?

Die Tabelle besitzt 9 Datenzeilen und 9 Spalten, diese sind korrekt gefüllt.
Reicht es nicht aus die gewollte Datenquelle für die Achsenwerte per Formel auf
das der tabellenspalte zugehörige Field zu setzen?


(Guest) #3

Hallo,

ich wollte fragen ob es hierzu schon eine Lösung gibt. Ich habe heute dasselbe Problem.
Ich benutze das Diagramm (Kreisdiagramm) und wenn meine Daten kurz sind wird das Diagramm nicht angezeigt.

Ich kann leider nicht sagen welche Version ich habe, da L&L ein Bestandteil des Softwares ist (CSS Group Filialmanager Easy SP1).

Ich bin für jede Hilfe sehr dankbar

Grüße
Phan Duc