+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

Problem beim einbinden von LL13 mit Lab/windows CVI


(Guest) #1

Hallo,

ich habe mir um 2 kleine Reports zu erstellen die Standardversion von LL13 gekauft, nun wollte ich diese in meine in C unter LabWindows/CVI geschriebene Applikation einbinden, also habe ich den Header und die .Lib datei in mein Projekt eingebunden und die entsprechende dll in das Projektverzeichnis geschoben.
Als ich meine Applikation dann Compilieren wollte bekam ich Fehlermeldungen die aus dem LL13 Header stammen.

“cmbtLL13.h”(1520,5) Invalid struct field declarations.
“cmbtLL13.h”(1520,5) syntax error; found 'identifier’expecting ‘}’.
“cmbtLL13.h”(1522,13) syntax error; found ‘{’ expecting ‘;’.

insgesamt bekomme ich 11 Fehler, kann mir bei diesem Problem jemand weiterhelfen?

MfG Matthias


(Guest) #2

Ändere im Headerfile

struct
{
//…
}

zu

typedef struct
{
//…
};

Paulchen

“Matthias Frömmel” <matthias02.froemmel@contiautomotiv…> wrote in
message news:30193718200816413@combit.net

Hallo,

ich habe mir um 2 kleine Reports zu erstellen die Standardversion
von LL13 gekauft, nun wollte ich diese in meine in C unter
LabWindows/CVI geschriebene Applikation einbinden, also habe ich den
Header und die .Lib datei in mein Projekt eingebunden und die
entsprechende dll in das Projektverzeichnis geschoben.
Als ich meine Applikation dann Compilieren wollte bekam ich
Fehlermeldungen die aus dem LL13 Header stammen.

“cmbtLL13.h”(1520,5) Invalid struct field declarations.
“cmbtLL13.h”(1520,5) syntax error; found 'identifier’expecting
‘}’.
“cmbtLL13.h”(1522,13) syntax error; found ‘{’ expecting ‘;’.

insgesamt bekomme ich 11 Fehler, kann mir bei diesem Problem jemand
weiterhelfen?

MfG Matthias


(Guest) #3

danke für die Hilfe


(Guest) #4

Gern geschehen. Da hatte wohl jemand nicht mit einem Uralt-C-Compiler
gerechnet :wink:

Pulchen

“Matthias Frömmel” <matthias02.froemmel@contiautomotiv…> wrote in
message news:5571723200894428@combit.net

danke für die Hilfe