+1 800 256 3608 (toll-free in North America) or +49 7531 90 60 10| service@combit.com

LL_OPTION_SKIPRETURNATENDOFRTF


(Guest) #1

Wir stellen gerade von LL7 auf LL15 um.
Dabei ist uns aufgefallen, dass LL15 die RTF-Texte anders interpretiert.
Das Standard-Control von Microsoft (RichTextBox) hängt bei RTF-Texten anscheinend ein \par an das Ende des Textes.
\par ist laut Spezifikation ein Zeilenumbruch.

Jetzt haben wir das Problem, dass zwischen jeder Datenzeile ein leerer Bereich entsteht. Quasi die Leerzeile.

In der Programmierer-Referenz steht:
LL_OPTION_SKIPRETURNATENDOFRTF
Am Ende von RTF-Texten können Zeilenumbrüche stehen.
TRUE: Sie werden entfernt (verhindert doppelten Abstand am Ende des RTF)
FALSE: beläßt die Daten so, wie sie übergeben werden (Voreinstellung)

Wende ich diese Option allerdings an, verändert sich gar nichts.

Wie muss ich die Funktion verwenden, damit ich keine Leerzeilen am Ende des RTF-Textes habe?

Wenn jemand ein Beispielprojekt (VB6) braucht, kann ich gern’ eins zur Verfügung stellen.

Vielen Dank


(Guest) #2

im ll15 header file habe ich diese option hier noch gefunden:

#define LL_OPTION_ENHANCED_SKIPRETURNATENDOFRTF (171) /* default: false. */

vielleicht hilft diese option weiter? ne doku dazu habe ich nicht gefunden
;-(

“Patrick Winkelmann” <mail@morphi…> schrieb im Newsbeitrag
news:3130782010154713@combit.net

Wir stellen gerade von LL7 auf LL15 um.
Dabei ist uns aufgefallen, dass LL15 die RTF-Texte anders interpretiert.
Das Standard-Control von Microsoft (RichTextBox) hängt bei RTF-Texten
anscheinend ein \par an das Ende des Textes.
\par ist laut Spezifikation ein Zeilenumbruch.

Jetzt haben wir das Problem, dass zwischen jeder Datenzeile ein leerer
Bereich entsteht. Quasi die Leerzeile.

In der Programmierer-Referenz steht:
LL_OPTION_SKIPRETURNATENDOFRTF
Am Ende von RTF-Texten können Zeilenumbrüche stehen.
TRUE: Sie werden entfernt (verhindert doppelten Abstand am Ende des RTF)
FALSE: beläßt die Daten so, wie sie übergeben werden (Voreinstellung)

Wende ich diese Option allerdings an, verändert sich gar nichts.

Wie muss ich die Funktion verwenden, damit ich keine Leerzeilen am Ende
des RTF-Textes habe?

Wenn jemand ein Beispielprojekt (VB6) braucht, kann ich gern’ eins zur
Verfügung stellen.

Vielen Dank


(Guest) #3

Super!!! =) Vielen Dank!!!

Das hat tatsächlich den gewünschten Effekt gebracht!
Wieso schreibt Combit diese Funktion nicht in die Hilfe?! :o

Nochmals vielen Dank

“Oliver Hambrecht” <o.hambrecht@onli…> schrieb im Newsbeitrag
news:4039279201010136@combit.net

im ll15 header file habe ich diese option hier noch gefunden:

#define LL_OPTION_ENHANCED_SKIPRETURNATENDOFRTF (171) /* default: false.
*/

vielleicht hilft diese option weiter? ne doku dazu habe ich nicht gefunden
;-(

“Patrick Winkelmann” <mail@morphi…> schrieb im Newsbeitrag
news:3130782010154713@combit.net

Wir stellen gerade von LL7 auf LL15 um.
Dabei ist uns aufgefallen, dass LL15 die RTF-Texte anders interpretiert.
Das Standard-Control von Microsoft (RichTextBox) hängt bei RTF-Texten
anscheinend ein \par an das Ende des Textes.
\par ist laut Spezifikation ein Zeilenumbruch.

Jetzt haben wir das Problem, dass zwischen jeder Datenzeile ein leerer
Bereich entsteht. Quasi die Leerzeile.

In der Programmierer-Referenz steht:
LL_OPTION_SKIPRETURNATENDOFRTF
Am Ende von RTF-Texten können Zeilenumbrüche stehen.
TRUE: Sie werden entfernt (verhindert doppelten Abstand am Ende des RTF)
FALSE: beläßt die Daten so, wie sie übergeben werden (Voreinstellung)

Wende ich diese Option allerdings an, verändert sich gar nichts.

Wie muss ich die Funktion verwenden, damit ich keine Leerzeilen am Ende
des RTF-Textes habe?

Wenn jemand ein Beispielprojekt (VB6) braucht, kann ich gern’ eins zur
Verfügung stellen.

Vielen Dank